Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
559 Posts
Discussion Starter #1
After a couple thousand miles they keep getting like this....



WTF:mad:

I either have to clean them or replace them otherwise it starts hesitating at high rpms
 

·
Registered
Joined
·
1,458 Posts
whats on them? sorry it looks like rust the pics, can you describe whats on them a little more.
 

·
Registered
Joined
·
559 Posts
Discussion Starter #3
IDK rust is exactly what it looked like at 30,000 miles when i changed them now at 34 it looks like oily gunk on it
 

·
Registered
Joined
·
559 Posts
Discussion Starter #4
bump
 

·
Premium Member
Joined
·
4,253 Posts
Might be rich and fouling the plugs...hard to tell, pics are blurry...

Are they black and wet when you pull them, or dry and rusty crusty looking?

What do you have for a tune? Any mods?
 

·
Registered
Joined
·
1,458 Posts
^I agree, mabey an air fuel guage would be a wise investment
 

·
Premium Member
Joined
·
22,435 Posts
The pictures aren't that great but they aren't going to be that clean. They generally look crusty and sometimes have a oil/fuel mix on the barrel of the plug. No issues.
 

·
Registered
Joined
·
559 Posts
Discussion Starter #8
well when i changed them at 30k they where dry and crusty but when i just pulled them out they are black and wet that pic is from 30k and a little oily up toward the top of the bolt.... i wouldnt worry about it but the car starts to loose power/ missfire? at high rpms and when i clean them it goes away and runs fine
 
1 - 8 of 8 Posts
Top