Modded Mustang Forums banner

1 - 20 of 31 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
im looking at a 98 gt and when i drove it, the speedo floats real bad and the tach works only part of the time. any ideas or suggestions what the problem might be and how to fix it. it does have 3.73 and the guy said he thinks that is the problem.
 

·
Registered
Joined
·
2,192 Posts
Welcome, I dont think the gears would cause it to not work. The gears would probably make it read wrong because you changed the ratio, but it shouldn't cause the problems you have. Sounds more like electrical to me. Pull the cluster out and check the pins and connections in it.
 

·
Registered
Joined
·
143 Posts
Discussion Starter #3
the problem is, that im thinking about buying it and it has these issues. the speedo just floats like some ol school car and the tach works when it wants. ive been looking and others say speedo gears
 

·
Registered
Joined
·
2,192 Posts
Speedo gears are for correcting your speedo whenn you change the gear ratio in the rear. I guess it could be bad and cause it to act funny. But it shouldn't effect the tach. So I still say somethings not right with the cluster itself. And if it comes down to it, say that's the only thing wrong and you want to buy it. You can always buy a cluster off craigslist, and take them apart and swap your mileage numbers out.
 

·
Registered
Joined
·
10 Posts
The problem with the Odometer is the odometer gears. They get super brittle and break and stop working. I just replaced mine. The speedometer sounds like a bad speedo head and you would have to get that part of the instrument cluster. If you did end up getting a new speedo head, it would come with new odometer anyway. Just FYI
 

·
Registered
Joined
·
143 Posts
Discussion Starter #7
all of the other guages seem to work ok just the tach and speedo are funny. i will probably get the car and put a new speedo gear and sensor in it to see if that does it, if not then i guess i will try a new cluster. the car did have an aftermarket tach installed at some point but not now. suggestions????????
 

·
Registered
Joined
·
250 Posts
speed sensor in the trans also causes it to float. check the wiring on the pigtail for frays. changing gears and not changing the trans gear causes the tach to go way high and tells your cluster your doing 90mph when in actuality youre doing 65. the floating could be the gear in the speedo sensor skipping a tooth when they could be chipped.

pigtail
sensor/ sensor cog
worm gears in cluster
tail shaft gears worn
cluster
 

·
Registered
Joined
·
143 Posts
Discussion Starter #11
im planning on buying the car tomorrow and hopefully will start the fixing problem sometime this week. if you have anymore suggestions, please let them be known
 

·
Registered
Joined
·
2,192 Posts
speed sensor in the trans also causes it to float. check the wiring on the pigtail for frays. changing gears and not changing the trans gear causes the tach to go way high and tells your cluster your doing 90mph when in actuality youre doing 65. the floating could be the gear in the speedo sensor skipping a tooth when they could be chipped.

pigtail
sensor/ sensor cog
worm gears in cluster
tail shaft gears worn
cluster
Didn't I already say all of that :eek:

Nobody pays attention to me :sorry
 

·
Registered
Joined
·
876 Posts
Just buy my cluster..................... Its worth a shot.
 

·
Registered
Joined
·
143 Posts
Discussion Starter #14
ok guys, i bought the car and it runs good. sometimes the tach works and other times not. i have smacked the dash and it will work for a bit then goes back out. as for the speedo, no dice, that thing has a mind of its own. planning on messing with it later this week. we shall see
 

·
Still slow.
Joined
·
8,738 Posts
The speedo doesn't run through the computer on the 98', it goes to the tranny instead. '99 is when it became through the computer. Id just go for a new cluster if i were you.
 

·
Registered
Joined
·
143 Posts
Discussion Starter #17
ok so i bought the car and im looking at speed sensors, i have found some at rockauto.com and they are very similar to the ones at lmr but cheaper. even the motorcraft one is cheaper! anyways, is it going to make a difference if i get a knock-off brand and where do i find the actual gear the sensor connects to? ive been reading and some say the gear itself starts loosing teeth and stripping
 

·
Rollin' 18/ pushin' 2
Joined
·
8,333 Posts
I just ordered one from late model resto. PM LMRjmac and he can get you the part number.
 

·
Registered
Joined
·
143 Posts
Discussion Starter #20
i got the part number from lmr but at rockauto its a better price. i found the gear itself at lmr. guess im gonna be doing some odering here before long. yesterday the car "tached out" im going like 45mph reading 15000 rpm's. hahaha, thought i was on my streetbike again.


zt i live in sanford, about 30 minutes south of raleigh
 
1 - 20 of 31 Posts
Top