Modded Mustang Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
548 Posts
Discussion Starter · #1 ·
i installed sportlines and a adjustable panard bar yesterday, all went well during the install but now i get a clunk-ing sound from all sides when ever i go over a bump or dip. im thinking its the bump stop in the back due to the fact that the frame rests on it with out an ppl in the car. is there anything else that would cause that sound if its not the bump stops?
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #3 ·
everything was tourqed to spec and no i didnt measure the height. we were in a small hurry casuse it was cold as crap
 

·
Registered
Joined
·
13,629 Posts
Also check and see if your springs ar in their mounts properly. The end of the coil in front should seat in the upper strut mount properly. These front strut mounts are clocked to a certain position. If they are not clocked right you may get some clunking from them. make sure the notch in the mount is facing the right direction.
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #10 ·
It could be the front strut mounts as well.
can you elaborate on what would about them would cause the issue?

Did you put the isolators back in?

( I know this seems like a dumb question but you would be amazed what gets overlooked when your in a "slight hurry" )
negative but ill fix them when i do the bump stops.

Tightned down your front swaybar and strut mounts
yes sir

Also check and see if your springs are in their mounts properly. The end of the coil in front should seat in the upper strut mount properly. These front strut mounts are clocked to a certain position. If they are not clocked right you may get some clunking from them. make sure the notch in the mount is facing the right direction.
by notch you mean the little arrow thing? yes i put them pointing outboard
 

·
Registered
Joined
·
1,427 Posts
can you elaborate on what would about them would cause the issue?
They front strut mounts are one time use only and they begin to pop and make noises if used more than once.
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #12 ·
they whole strut was a used one from a friend. where can one buy replacment front struts at?
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #14 ·
they were on the spring but they were not all the way on the bottom of the spring. te only thing i saw on the spring way a rubber tube that went up a few coils on the spring.

its not really a pop its a clunk but ill fix it either way
 

·
Registered
Joined
·
217 Posts
what kind of panhard bar? the reason I ask is because I installed one with delrin-sphere bushings which allow some swivel and I've noticed that the bushings clunk into the brace around the area that the panhard bar mounts in. It's completely quiet unless I go over weird bumps, and potholes etc...
 

·
Registered
Joined
·
548 Posts
Discussion Starter · #17 ·
BMR adj w/poly bushings
havent had time to fix the issue do to flying at work will do on wendsday and report back.

attached is a pic of the drop. enjoy
 

·
Registered
Joined
·
13,629 Posts
Was there anything that looked like this?



THese should be firmly mounted on the top and bottom of the springs...
I don't think I have anything like those on my car.

Edit: I'm trying to think back. There are a couple of little things on the axel where the springs sit. I don't think they looked like that though.
 

·
"Spectre" Veteran
Joined
·
492 Posts
They front strut mounts are one time use only and they begin to pop and make noises if used more than once.
Or if you live in Florida and drive through construction sites regularly...you'd think that they'd have better roads by now with this constantly going on. :mad:
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top