Modded Mustang Forums banner
1 - 13 of 13 Posts

·
Sheriff Metal Face
Joined
·
5,579 Posts
Discussion Starter · #1 ·
The other day I changed my header gaskets and I changed 2 cracked spark plugs because I guess I over tightened them months ago when I put them in. I went to fill up for gas literally right after I finished and my car started sputtering with 1/4 throttle or less. The sputtering feels the same as when there is moisture in the dizzy cap. But I didn't even change anything. firing order is correct. Could the 2 new plugs along with the old ones make it run different? Or did I get bad gas? I'm also getting like 8mpg now too. I went through 3/4 of a tank in less than 2 days. After I filled up it ran a little better but it still sputters. Any help would be great. I'm gonna let the tank all the way to empty and see but i'm kinda stumped
 

·
Registered
Joined
·
4,356 Posts
I have never changed only two plugs at once, and i dont know if that would make a difference or not, when is the last time you changed your fuel filter or plug wires?
 

·
Sheriff Metal Face
Joined
·
5,579 Posts
Discussion Starter · #3 ·
I have never changed only two plugs at once, and i dont know if that would make a difference or not, when is the last time you changed your fuel filter or plug wires?
plug wires are 2 months old and fuel filter is a little less than 3 months old. And I've never only done 2 plugs either..
 

·
Registered
Joined
·
4,356 Posts
did you buy a cheap or quality fuel filter?
 

·
Billy Weston
Joined
·
5,076 Posts
Check for codes yet? Does it seem like a dead miss, random miss? running rich? Know much about a DVOM?
 

·
Sheriff Metal Face
Joined
·
5,579 Posts
Discussion Starter · #11 ·
I changed all the plugs tonight and it runs perfect now, so it was because I put 2 new ones in with old ones. I'm never changing a couple plugs at once again lol. Thanks for the help guys
 

·
Registered
Joined
·
4,356 Posts
awesome, lucky it was such a cheap fix
 
1 - 13 of 13 Posts
Top