Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Replaced my rear shocks recently with no name brand OEM shocks now about a month later my rear end makes a squeaking sound when i push down on the rear end?

I dont hear it when i drive mostly just when i am getting out of my car and the suspension lifts or when i push down and let it bounce back up.

any ideas would be great.
 

·
MM's Samsquanch
Joined
·
707 Posts
did you just do shocks or did you do the springs at the same time? do you have spring isolators in the rear?
 

·
Registered
Joined
·
164 Posts
could be the control arm bushings as well
 

·
Sarcastic Sally
Joined
·
3,352 Posts
I could be wrong, but cant new springs make that kind of noise for a bit until they get broken and firmly seated in?
 

·
Registered
Joined
·
164 Posts
possibly if there were new isolators used but with it only being a shock change I'd say it's most likely a control arm bushing, mine did the same thing until I changed them out actually. If you get some white lithium spray on grease and spray the bushing on both sides between the mounts it should quiet it down for a little while, and you''l know what the problem was. also check the torque on your lower shock bolts just to be safe
 

·
Registered
Joined
·
108 Posts
Discussion Starter #7
Alright cool. it hasnt been bad lately so i kinda forgot about it but it is still there. and it was just my shocks i replaced. i have BBk lowering springs they are couple years old. and for the isolators i have no idea. never seen them never touched them hahaha.!
 
1 - 7 of 7 Posts
Top