Modded Mustang Forums banner
1 - 11 of 11 Posts

·
The UPS guy
Joined
·
3,232 Posts
Discussion Starter · #1 ·
my engine is squeking like a bitch....ive changed the main belt 3 times already...its always fine until its humid out or rains....then it squecks very badly again...my dad thinks it was the alt. but now hes starting to think the pullies are worn out...car just rolled 100k...any help? its so embarrassing!!!:mad:
 

·
The UPS guy
Joined
·
3,232 Posts
Discussion Starter · #9 ·
lmao...so new tensioner pully???? well the first time i bought a new belt it was from autozone...and it was a tad to big i think and thats why it started squecking...then the 2nd time i got it from ford...it was good all summer long...then changed it AGAIN with a ford one....that was in oct...it was good until about a month or so ago but only when it rained to was humid...or whenever it felt like it...thats when my dad said it has to be one of the pullies....so tensioner???
 

·
The UPS guy
Joined
·
3,232 Posts
Discussion Starter · #15 ·
ok...i'll go tomorrow to ford....i feel like im there everyday...i should have just gotten a new gt when i had the chance...i hate used cars...my car is falling apart...engine mount broke...squecky ****...tailpipe rusted off muffler...clutch pedal vibrates likes crazy coz the cable is shot...dash lights dont lightup anymore...the list goes on....
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top