Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
i changed my belt last week and ever since its been squealing pretty loud i sprayed belt dressing on it and it gets worse sound like its coming from near the water pump any ideas its driving me crazy:mad:
 

·
Registered
Joined
·
118 Posts
Discussion Starter #3
yes i have ps alternator and under drives i had a 73.5 on it that was a bit loose so i went to a 73 and thats when it started it gets a little louder after it runs a while and the belt dressing makes it get alot louder i spun all the pulleys with the belt off and none squeaked the belt is the orielly brand if that matters
 

·
Registered
Joined
·
1,021 Posts
maybe one of the bearings is going bad in a pulley, and the new tighter belt is really making it noticeable? My idler pulley bearing went bad on my explorer and it was making a squealing sound until it welded itself up and unscrewed itself haha
 

·
Registered
Joined
·
11,200 Posts
I had my tensioner pully seized one time and it made that noise, at first i didnt notice it
 

·
Banned
Joined
·
3,385 Posts
Take the belt off and spin each pulley by hand if possible or with the belt off start the car and see if the noise is still there.. if it is then it's not a pulley issue
 

·
Registered
Joined
·
118 Posts
Discussion Starter #8
ive done all that when i spun each pulley none made noise and with the belt off it stops i kinda think the oreilly belt is just shity quality i had a gator back on it that was a half inch to big and it never made a noise and worked good i think im going to try another belt and see if it stops
 
1 - 8 of 8 Posts
Top