Modded Mustang Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
my '87 stang won't start when its really cold and windy outside for some stupid reason, i know the fuel pumps tend to go out a lot in the '87s. i don't know if its just a cold battery or i have an exposed or pinched wire somewhere. anyone have an idea what it could be?
 

·
Registered
Joined
·
2,950 Posts
could you describe how or why it doesnt start......does it turn over really slowly or does it not crank at all....?????
 

·
Registered
Joined
·
82 Posts
Discussion Starter #3
the way i usually start the car is a turn the key to see if i hear the fuel pump kick in then i turn it over, but on those cold days i don't hear the fuel pump. i don't think its a bad battery because it powers everything else like the radio and the lights, etc.
 

·
Registered
Joined
·
569 Posts
fuel pump, fp relay
 

·
Registered
Joined
·
569 Posts
check if the relay is clicking when you cycle the key you can feel it
 

·
Registered
Joined
·
82 Posts
Discussion Starter #7
i could feel it. today when i get home from work i'm going to trace the wiring harness for the fuel system to see if i can find any bad wires, and see if i need to replace the relay again.
 

·
Registered
Joined
·
569 Posts
if it clicks it is working, probably a bad pump in your case
 

·
Registered
Joined
·
146 Posts
yea if the pump clicks then the wires are not shorted out the pump prob. went bad if its original its over 20 years old just change the pump
 

·
Registered
Joined
·
82 Posts
Discussion Starter #13
well after further inspection of my engine bay, and looking at a wiring diagram, it turns out the tan wire with light green strips that goes from my eec to my fuel pump relay isn't in my fuel pump relay connector!!! i don't know where the wire is at and i don't know where my computer is located!
:eek:
 

·
Registered
Joined
·
569 Posts
it didnt just dissapear one day lol?
 

·
Registered
Joined
·
82 Posts
Discussion Starter #15
yeah i know but it still is not on the connector and i don't know if it goes into the firewall to the eec or what
 

·
Registered
Joined
·
569 Posts
it goes to two places, your computer at the 22nd pin and back through the firewall to you self test input its shaped like a house on the driver side right next to the firewall
 

·
Registered
Joined
·
82 Posts
Discussion Starter #17
oh ok. i looked at the tan wire on the self test input and followed it into the firewall but i didn't see where it spliced to the fuel pump relay
 

·
Registered
Joined
·
4,781 Posts
how many wires do you have at the relay? should be 4, the colors might be different.

If you are really missing the wire that goes to your computer, your relay wouldn't click when you turn the key.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #19
i didn't know that the wires could be different colors than what the book says. the relay has a red wire, a black wire with a yellow or green stripe, a pink wire with a Lt blue stripe, and an orange wire with a Lt blue stripes. isn't the red wire supposed to be a fusible link or circuit with the wire that goes to the computer.
 

·
Registered
Joined
·
569 Posts
all your wires are there...like ryan said theres only 4
 
1 - 20 of 29 Posts
Top