Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,358 Posts
Discussion Starter #1
This comes up about once every week or two and has been driving me crazy. While driving my temperature knob suddenly wants to "spring" back to hot. If I move it to the middle it immediately goes all the way back to hot. I'm able to get it to stick on fully cold most of the time but it's still under pressure trying to go to hot. After leaving my car off for a few minutes it seems to go back to normal.

Are our controls run from a vacuum line? I'm wondering if somehow having boost in that messes things up.

Any insight would be appreciated.
 

·
Registered
Joined
·
1,358 Posts
Discussion Starter #2
Anyone have any ideas or heard of this happening before?
 

·
Registered
Joined
·
37 Posts
Yes, the climate control actuators are controlled by vacuum. Though, I personally have never heard of things being messed up by any sort of boosting.

Just to be clear, the actual knob is turning?
 

·
Registered
Joined
·
1,358 Posts
Discussion Starter #4
Yes, the climate control actuators are controlled by vacuum. Though, I personally have never heard of things being messed up by any sort of boosting.

Just to be clear, the actual knob is turning?
Yep, it's really hard to turn towards cold and just springs back to all the way hot when this is happening.

I'll play around with changing it while in boost and see if I can figure out if that causes it.
 

·
Registered
Joined
·
398 Posts
if i turn mine all the way hot it clicks back one notch. it wont stay all the way it always clicks back. kinda weird but not really problem.
 
1 - 5 of 5 Posts
Top