Modded Mustang Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
I've had my 6er for about a year now and ever since I had it it had a rattle that I thought was just the tob which grenaded on my recently so I put in a net clutch and bearings but this didn't fix the rattle(paint can type rattle under medium-heavy acceleration) so I did some googling and found that it might be spark knock so I put some premium in and ran her out pretty hard and it seemed to fix the problem. Now what I want to know am I stuck paying for premium or is there an alternative fix?
 

·
I love to skydive
Joined
·
17,286 Posts
Might be the tune.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
I have a stock tune. I had a sct chip but I never got to use it because I took too much off the contacts and it wouldn't connect so now I have to buy a handheld, would that be recommended?
 

·
Registered
Joined
·
390 Posts
I've had my 6er for about a year now and ever since I had it it had a rattle that I thought was just the tob which grenaded on my recently so I put in a net clutch and bearings but this didn't fix the rattle(paint can type rattle under medium-heavy acceleration) so I did some googling and found that it might be spark knock so I put some premium in and ran her out pretty hard and it seemed to fix the problem. Now what I want to know am I stuck paying for premium or is there an alternative fix?
i seem to have the same problem with what i think is stock tune and i was wondering if you have the 10% ethenol 87 fuel there in texas. does your temp guage climb quickly when you accelerate fast?
 

·
Registered
Joined
·
390 Posts
Check the gap on your spark plugs, then check your coil pack.
how could coil be related? i have a lean code and a slight pre-ignition but the engine pulls hard. cold engine feels a bit rough. also noticed that removing cam sensor makes no difference other than a code for it. 93 seems to stop dieseling at lower speed high throttle percentage.
 

·
hi you can call me mater
Joined
·
4,845 Posts
It could be your spark plugs

03cristian
 

·
Registered
Joined
·
390 Posts
how could coil be related? i have a lean code and a slight pre-ignition but the engine pulls hard. cold engine feels a bit rough. also noticed that removing cam sensor makes no difference other than a code for it. 93 seems to stop dieseling at lower speed high throttle percentage.
i know my plugs are good, they are motorcraft with less than 10000 miles and i checked gaps. anyone know if these coil packs have circuit boards or any kind of transistors inside?
anyone know if eec5 can be remotely hacked up like a desktop pc on the internet? lol
 

·
R.A.D
Joined
·
5,413 Posts
i know my plugs are good, they are motorcraft with less than 10000 miles and i checked gaps. anyone know if these coil packs have circuit boards or any kind of transistors inside?
anyone know if eec5 can be remotely hacked up like a desktop pc on the internet? lol
:facepalm: if you checked the gap then, what are they set at? and don't research on what the gap is supposed to be.:bubba:
 

·
Registered
Joined
·
96 Posts
Discussion Starter #11
We have 10% ethanol here too. I'm going to pull the plugs tomorrow and throw some new ones in because idk how old these are. I am also getting oil from the PVC valve but I put a inline filter on it and it seems to be working but I think I'm going to just switch out the valve covers over the break. Hopefully one of those fixes it because premium is $.40 a gal more over regular
 

·
Registered
Joined
·
96 Posts
Discussion Starter #13
And the only code I keep getting thown is the vac code and its either my egr or the gas cap but each time I reset it its gone for a couple of weeks then comes back. Kind of a pita but it doesn't bother me too much
 

·
R.A.D
Joined
·
5,413 Posts
And the only code I keep getting thown is the vac code and its either my egr or the gas cap but each time I reset it its gone for a couple of weeks then comes back. Kind of a pita but it doesn't bother me too much
Clean your egr. Also with the gas cap, Yes it can cause the cel to go off, but it would show the gas cap light all the way to the right.
 

·
Registered
Joined
·
390 Posts
i gapped my plugs to what the guy at the ford dealer wrote on the box, forget what it was i think 044. back in 08 i had a thermostat stuck open and a bad 12v + short to ground at the same time, enough that it blew my headlights bulbs out before i searched it out. i think i have got pre-ignition because what i did a few months ago after dealing with harsh engine vibration, glogging cats and terrible fuel mileage since 08 i installed a 95tbird 4.6v8 maf sensors and all the trouble seems to vanish. ithink either my maf, or pcm died or reprogrammed itself, not sure. but with the original maf the engine is horrible.
can adaptive reprogram itself to pig rich with crap spark advance curves? or could bad short have half way fried it?
i spent wayyy to much time trying to get this eng. back to perfect but with the v8 maf it does pretty good. i thought i had the dieseling problem fixed when i removed and bench cleaned the injectors but it came back eventually as if some of the injectors jets clogged again.
 

·
Registered
Joined
·
390 Posts
gap is supposed to be .054
im sure thats what it is then. i never screwed up on setting plugs on anything cars, trucks, bikes, lawn mowers, you name it. any idea why i get a lean back 2 at about 80-90 throttle. i dont think it does it if i jam it to wot.
i took the injectors out and found bank 2 had some with plugged jets but i opened them up. they all have 250k miles, should i get them flow checked ?
you dont think the 95 tbird 4.6 maf is a problem? it deffinetly improved the eng performance and took fuel mileage back to 28mpg when it used to be 18 highway with old maf.
 

·
Registered
Joined
·
1,666 Posts
Logically, the difference between premium and regular is just octane, they all have the same detergents etc..
Unless you're car is severely nodded I doubt you're stuck with premium.
Upload a pic of your spark plug!
 
1 - 20 of 28 Posts
Top