Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
i have a audiobahn a8000T amp powering two pioneer subs in my 06 mustang and it doesnt bump like subs should. its like theres not much power coming from them. ive adjusted the amp but still it still gives a vibrating sound and not a thump. if this makes any sense please give me some advice
 

·
_
Joined
·
3,782 Posts
What kind of subs are they?

That amp is rather powerful, it should be able to squeeze out 400 watts RMS per sub at 2 ohms.

Some things to check: check the fuse on your amp power wire, make sure its not like hanging on by a thread. Check the fuse(s) on your amp for one or more being possibly blown.

One more thing, have you installed UPD's recently? Or found our alternator to be crapping out a bit?
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
[/URL] Uploaded with ImageShack.us[/IMG] not sure of the model number though but heres what they look like
 

·
_
Joined
·
3,782 Posts
Yes, check those green fuses on your amp. UPD's? Another thing, if its in the car,try them again and feel your hand around the box and subs seals for leaking air.
 

·
Registered
Joined
·
3,357 Posts
what settings on the amp do you have? and how far did you turn the gain up before they started "buzzing"

audiobahn has never been known for anything quality. honestly i would look into getting a better amp
 

·
Registered
Joined
·
200 Posts
Did it all work before you put it in the car or is this a new issue? Any burnt smell from the drvers or the amp? Do you hear any crackeling? When everything is off and you push on the cone is it smooth, stickey or grab in spots and get stuck. If yes you blew something up. Sounds like a bad amp to me tho.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
yeah it all worked fine and sounded fine to me till my brother listened to it one night and said that it doesnt sound like it should. and since then its bugged me that it isnt right haha. but ill check into all the advice you guys gave i appreciate it all
 
1 - 7 of 7 Posts
Top