Modded Mustang Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,598 Posts
Discussion Starter #1
So when I accelerate, above 2000 rpm I hear a tapping kind of noise that goes up with RPM. But I only notice it above 2000 rpm. And only when under load. Is my tach or Speedo F'd or what?
 

·
Registered
Joined
·
3,200 Posts
exhaust leak at the manifold?
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #3
I do have an exhaust leak, but it is at the collector, and a different noise. I know that one. This is only when accelerating and it sounds like its coming from inside the dash, right above my left knee. Its really weird.
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #6
I only hear it at like 2k to 3k. and mostly just 2nd gear. I can't figure it out.
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #8
No, I have an EGR. Its at probably 3/4 to full throttle.
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #10
Yeah kinda, its a canned based on my mods. But its tuned for 91 and I run 92. Not a huge differance, but its not like I should be pushing the limits.
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #11
So, update. With my radio off, I can hear a squealing rubber kind of noise when I accelerate and brake. I think one of my motor mounts is either going bad or just old. Either way, i'm not sure if that would make the noise I have been hearing. Its only on the driver side of the car. It all started shortly after I got my subframe connectors installed.
 

·
Registered
Joined
·
1,598 Posts
Discussion Starter #13
Header Heat Shield? Where is that? I have LT's and a small exhaust leak? Is it a product of the leak? or what?
 
1 - 13 of 13 Posts
Top