Modded Mustang Forums banner

241 - 260 of 271 Posts

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #241
Dropped some parts off at the powder coater today. Car goes in the shop next week.


Sent from AutoGuide.com App
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #244
Things are getting serious now.



 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #248
chopped the rear sway bar brackets and installed the BMR relocation kit. Then I test mounted my 15" racestars.



 

·
PhD in Procrastinology
Joined
·
4,897 Posts
Subb'd for track times. Build looks awesome...avatar needs work. Rep the star MAN!
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #250
Subb'd for track times. Build looks awesome...avatar needs work. Rep the star MAN!
Been a fan all my life... Avatar is how I feel after every season nowadays.
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #252
Looks awesome man!

What kind of intercooler are you running?
Air to air. It's the kit that comes with a Paxton. I believe it's a turbonetics intercooler.
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #257
I hated the Exedy Mach 500 so much, I bought a McLeod RST. Clutch and flywheel are here. Maybe I'll get it installed this week or next. I also got everything to switch to a blow through set up. I just gotta get some parts welded and some powder coating done and I'll get that set up going.

I'm waiting on a custom coolant expansion tank I'm having made, then I'm going to do the battery relocation, coolant tank in the battery location, and install my nitrous kit.

I need more hours in a day.
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #258
Not build related but here's a cool video a friend of mine made for me:

 

·
taylor21pierce snapchat
Joined
·
758 Posts
Sick man! Don't you think your trap speed is a little low for 523rwhp? I'm running a vortech v3 and at 425rwhp trapped 111mph now I'm making 485 so just curious on if maybe your cars pulling timing like mine did at 5500rpm one of my knock sensors would pick up engine noise and pull timing. Would only do it driving around not on the dyno. Might be somthing to check out.
 

·
3v reppin'
Joined
·
3,454 Posts
Discussion Starter #260
Sick man! Don't you think your trap speed is a little low for 523rwhp? I'm running a vortech v3 and at 425rwhp trapped 111mph now I'm making 485 so just curious on if maybe your cars pulling timing like mine did at 5500rpm one of my knock sensors would pick up engine noise and pull timing. Would only do it driving around not on the dyno. Might be somthing to check out.
I thinks it's because my water pump isn't pumping enough water. I switched to an electric pump and ever since I've had high coolant temps. My car gets super hot under load so it's pulling timing. I'm pulling the pump and putting a stock pump back in soon. Just been busy with work.


Sent from AutoGuide.com App
 
241 - 260 of 271 Posts
Top