Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter #1
Hello, just wondering if any of you can tell me what my temp gauge is acting up for? Most of the time it never moves off C, but at times while i'm driving it'll go up to normal. It might stay there till i turn the car off or it might go back to C in a few min. Been doing some reading and seems like there hasn't been an ECT for some time, but rather a CHT, cyl. head temp. I was just wondering if this is correct and if anyone knows where this is at on the engine. Also just got a tuner and it's saying the temp is around 60-63. Thanks for any help
 

·
Registered
Joined
·
13,628 Posts
Hello, just wondering if any of you can tell me what my temp gauge is acting up for? Most of the time it never moves off C, but at times while i'm driving it'll go up to normal. It might stay there till i turn the car off or it might go back to C in a few min. Been doing some reading and seems like there hasn't been an ECT for some time, but rather a CHT, cyl. head temp. I was just wondering if this is correct and if anyone knows where this is at on the engine. Also just got a tuner and it's saying the temp is around 60-63. Thanks for any help

Wait, 60-63? Is that in Celsius? That's still only like 150 F. That's not right either way. And from what it sounds like it's an electrical issue with either the wiring or the sensor itself. From the fact that it's sometimes reading normal, I would lean toward the wiring. But I don't understand why you are data logging 60-63 for CHT.

If it is the sensor, I couldn't pinpoint it for you, but it's on the inside of the right cylinder head, facing the engine valley. That's about as close as I can get you. I don't know if it's accesable without taking stuff apart either.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #4
Haven't checked the t stat but it's heating good just figured I'd try the sensor first just hoping I didn't have to pull the intake off. If I do are there any gaskets I have to buy?
 

·
Registered
Joined
·
11,354 Posts
She may be low on coolant. If not id just replace the senor.

The sensor should only be reading in F by the way
 
1 - 5 of 5 Posts
Top