Modded Mustang Forums banner

1 - 20 of 26 Posts

·
Premium Member
Joined
·
33,198 Posts
Discussion Starter #1
my IMRCs were clogged, which i planned on taking care of myself when i had the time to tear the car apart, so i just parked it. i needed to go somewhere last night and my cobra was the only thing i had with gas in it, so i hopped in it and started it up and got a crazy knock, like somebody pounding on the engine with a sledgehammer, then what sounded like a short whistling, then it went dead. started it back up, it idled, but lower than usual, and the knock was just as bad. loud and shaking the whole car.

what could this be exactly? i already knew i was going to have to do work on it, but this was unexpected. i guess i'm just gonna have to leave it in the garage, throw a car cover on it, and let it sit until i can afford to spend the time and money on it :sorry

i thought about just selling the car all together, but then i pulled my head out of my ass and realized it has way too much sentimental value. maybe i'll just let it sit until i can forge the bottom end, port the heads, and buy a supercharger. :dunno
 

·
Bringing Yellow Back
Joined
·
10,928 Posts
wow that sucks dude, i would drain the oil and inspect, maybe your clutch is ****ed up?
 

·
Registered
Joined
·
1,629 Posts
Nooo!! that suck hard core. I want to say it's something beyond the IMRC's...but I just don't know enough to guess...lets hope its an easy fix
 

·
Better than Drugs!
Joined
·
2,064 Posts
I agree with draining oil, inspect. Remove the dust shield (clutch cable cover under trans) and try to inspect. Hopefully its nothing too bad. Maybe pull a few plugs and inspect too.
 

·
King Trashmouth
Joined
·
21,891 Posts
maybe i'll just let it sit until i can forge the bottom end, port the heads, and buy a supercharger. :dunno
:yes

That sounds pretty severe though. I could be wrong, but you did use the word "sledgehammer." Check for metal in the oil, holes in the block, or fluids everywhere. If there's none of that it might not be so bad. In relative terms of course.
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
+1 on oil pressure Bubba?

Also, give Mike a call. See if he can help ya out. You're closer to him than me :lol
 

·
Premium Member
Joined
·
33,198 Posts
Discussion Starter #9
thanks for all the reponses.

i do have oil pressure.

i started it up again a little while ago and it started up real weird. the knocking is still there, but it's slightly gentler now. it also seems like the idle may have gone back to normal
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
Way to break your **** Bubba :lol
 

·
Better than Drugs!
Joined
·
2,064 Posts
This 97 I know of has a knock but has IMRC delete plates. I dont even know what they are. WTF are they?
 

·
Registered
Joined
·
1,259 Posts
intake manifold runner control
 

·
Premium Member
Joined
·
12,055 Posts
kinda sounds like when rats chewed the wires in my car... twice. check the wires for any visible chew marks.
 

·
Better than Drugs!
Joined
·
2,064 Posts
BWAL-- I have the same problem man. Just picked up this 97 today, it has no imrc's and there is a knock above 2k pm. Low on power but god oil pressure stil wtf is going on? Did u ever figure yours out yet??
 

·
Better than Drugs!
Joined
·
2,064 Posts
You think so? Well I cant tell if its low on power or not, really. I just got rid of a 95 cobra, ya know, the low end torque. So maybe it isnt but I havent tried to run it hard yet. I heard the knock and drove her easy. SORRY TO THREAD JACK! It still revs quick in neautral or with the clutch in, but when I shift i can hear it knock. The engine in the car now has only 13000 miles on it (remanned engine--still a cobra 4 v) oil is clean, pressure is good, no other noises. Really not a single noise anywhere on the whole car when running. OH btw number 6 spark plug had oil on the thread. didnt know if that would have anything to do with it. what would be the cause of the oil on th eplug? I checked all the others and they were fine.
 

·
Premium Member
Joined
·
8,732 Posts
No im thinking bwals is a rod. Yours sounds like it could be detonation. Possible the previous owner was running 87 octane and you havent flushed it all out yet?
 

·
Premium Member
Joined
·
33,198 Posts
Discussion Starter #20
You think so? Well I cant tell if its low on power or not, really. I just got rid of a 95 cobra, ya know, the low end torque. So maybe it isnt but I havent tried to run it hard yet. I heard the knock and drove her easy. SORRY TO THREAD JACK! It still revs quick in neautral or with the clutch in, but when I shift i can hear it knock. The engine in the car now has only 13000 miles on it (remanned engine--still a cobra 4 v) oil is clean, pressure is good, no other noises. Really not a single noise anywhere on the whole car when running. OH btw number 6 spark plug had oil on the thread. didnt know if that would have anything to do with it. what would be the cause of the oil on th eplug? I checked all the others and they were fine.
this sounds a lot like the problem i'm having, but i haven't tried to drive or shift it.

i'll try to isolate the sound if i can
 
1 - 20 of 26 Posts
Top