Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter #1
getting a leak near the passenger side front on an AOD. Looks like its coming from the top cooler line but im not sure. car hasnt moved in 3 months, just started doing it the other day.

I was under there and I think I may have moved the lines a bit. Is there a seal or something on that line. I made sure that it was tight and it was. But it looks like it still leaked some.

Lost about a half a quart over night. I made sure to clean everything off and the only spot I saw some was from the line and just below the line. I guess where it dripped down and ran over the edge of the pan.
 

·
Registered
Joined
·
1,716 Posts
the fittings the lines are screwed into are just screwed into the case using pipe threads. just probably needs to be tightened or if they are tight, take them out and apply some teflon tape to them and screw them back into the case, BUT DON'T OVERTIGHTEN... could also be the dipstick tube on which there is an o-ring.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #4
my lines dont screw into the fittings, it looks like it just has some plastic clip holding them in. Where can I get a new oring for the dipstick?
 

·
Registered
Joined
·
1,716 Posts
ahh, you have the old style fittings. There is a kit made to replace/update those to the new style thaat seems to work very well. As for the dipstick tube o-ring, stop by the shop tomorrow and see me. I've got a bunch of them laying around
 

·
Registered
Joined
·
248 Posts
Discussion Starter #6
Twist 2 Go said:
ahh, you have the old style fittings. There is a kit made to replace/update those to the new style thaat seems to work very well. As for the dipstick tube o-ring, stop by the shop tomorrow and see me. I've got a bunch of them laying around
ford part number on the kit? or is it aftermarket. I think I still have your number in my phone, i'll give you a call sometime to get one from you.
 

·
Registered
Joined
·
248 Posts
Discussion Starter #7
looks like it was the dipstick tube. must have bumped it putting the header on. thanks guys.
 
1 - 7 of 7 Posts
Top