Modded Mustang Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi, I have a built 5.0 mustang and in the last week it has fouled up and cant seem to trace the issue down. Was driving down the interstate got off the exit and when I did the gas pedal became unresponsive and the car spit and sputtered to a stop. Got it started again made it a block or so and it died yet again. Realized the water pump had seized up, replaced that thermostat and radiator cap. The car is heavily modded and on a good day runs 11s down the track. Im out of work right now and just want to race this summer not waste it away chasing down a problem I cant find. Its got a 6AL MSD ignition module and MSD cap ford racing plug wires. Car wont start once it dies for a few hours then it will start and do the same as long as its cold and I start it up get it on the interstate it will run as long as im on once I get off it dies. Anything you guys could help troubleshoot would be great. Had a great mechanic for awhile but he has since moved away and Im only average at working on cars. Replaced water pump myself though it took two evenings : /
 

·
Registered
Joined
·
325 Posts
Have your tfi module tested. Autozone does it. If it is bad, ONLY replace it with Motorcraft or standard motor products parts. It could also be the pickup coil inside the distributor. If that's the case, you're better off replacing the whole unit. Also check for codes. Let us know how you make out.
 

·
Registered
Joined
·
325 Posts
How about plugging in your MAF sensor, lol. It looks unplugged in your pic. Check for codes is the best thing to start with. Try that first and report back, it takes 10 minutes.
 

·
Registered
Joined
·
408 Posts
Is your car carbureted? I looked it up and this seems to be a common problem with carburetors.

here
AOL Search

edit: oops, just saw ur engine bay pic. check out the link anyway
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
yea....hasnt had a maf sensor in a long time...lol something about swapping all the throttle bodys and throttle spacers out im not sure but plug has been cut out couldnt plug it in if i wanted to been run probably 5k miles like that issue free until friday of this past week. use to drive it all the way to the strip think im going to start towing it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
no its a fuel injection system if i remember correctly its 24lb injectors maybe wrong but i think thats whats in it. Electric fuel pump not sure if its in tank or in line. I hear it turn on when key is in the on position.
 

·
Registered
Joined
·
325 Posts
Ok, id still have that tfi module checked out. Mine did the same thing so I'm speaking from personal experience. I replaced the whole distributor though to be on the safe side. So, you're saying you can cruise on the interstate for as long as you want without the car dying on you?
 

·
Registered
Joined
·
191 Posts
i believe you have 19lb injectors (i can see the orange tips) mass air or no mass air do like the others are saying tfi module and or swap dizzy
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
I just got back the car died today after getting back from the team garage i used to put the water pump on car was only 15 minutes from the house but ran fine down all the back roads stop and go traffic and all. Temp gauge wasnt working before the water pump stopped working but when it went I did the usual maintenance and swapped thermostat and radiator cap and now gauge seems to be working fine its not overheating just seems like when its really hot out (80-90s) it shuts down. Team mechanic (chevy guy) says the reason it wont start back up is bc the starter is binding he thinks. Going to clear the garage and start working out bugs in the morning. It really has run fine without the MAF and so far have not had a check engine light once in this whole thing. MSD cap and wires have less than 5k miles on them is usually kept under cover and oil changed with royal purple every few hundred miles or after every race. I dont think I have a TFI module I cant seem to find it under the hood can anyone find it in that pic?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Im pretty sure it is a speed density car not 100% sure but last year (when I was working overtime everyweek and could afford to build this) The mechanic I had building this was discussing the options of running both ways with the SD vs MAF I just cant for the life of me remember which way we went how can I check it?
 

·
Registered
Joined
·
6,990 Posts
TFI is on the distributor and most likely your issue. If it's not that, then it's the fuel pump. I didn't read through all the posts, but I'd bet money on it being one of the two!
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
I havent talked to him at all about the tfi yet, all he was concerned with was making sure I got the water pump on he had paying work to attend to I tied up the shop for two days already which I understand I just race for him...when my car runs
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
ok can i replace just the tfi or do i need to replace the whole distributor? it is getting old now going on 5 plus years car only has 88k as of last year, speedo cable broke on the strip : )
 

·
Registered
Joined
·
325 Posts
Ok, if its speed density, that explains why your car works without the MAF. As said, the tfi is the electronic piece mounted on the distributor with the wires going to it, right next to the spout connector. Don't pay attention to the dummy lights on the dash, you have an 88, there is no CEL. Even though you see it in the cluster, trust me, it won't work. Go pull the codes. If you don't know how, ask. I bet its either the tfi module or the pickup coil.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
ok well I will give that a try in the morning and take it to advanced first they are only 5 min away and have all but charged me rent for the time i spend there. Thanks guys for all your help ill post an update in the morning.
 

·
Registered
Joined
·
325 Posts
You can replace just the tfi but get it tested. You may also need to buy the special tool to take it off. Autozone $5. And read the first post I wrote in this thread or you'll be in the same situation, again.
 
1 - 20 of 23 Posts
Top