Modded Mustang Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
1,143 Posts
Discussion Starter #1
Well got the Hellion finished today and this thing is a beast when it kicks in!

Made 420RWHP/415RWTQ with 20" heavy Foose wheels, 100 degrees, and only 7psi!

My question, car wants to stall everytime I get into boost then push the clutch in, I know it has to be the extra pressure from the turbo being spit out of the BOV which is located near the air sensor... so it is almost certain that the "wasted" boost is getting to the MAFS, could it be that the BOV is not letting all the air out like it should?
 

·
Registered
Joined
·
1,341 Posts
u dont have a BOV,
u have a bypass where the compressed air is sent b4 the MAF which then decompresses.. you have a tuner problem... who tuned it?
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #4
it's not a tuner problem, the AF is dead on! It happens when I am getting out of hard boost and letting off by punching the clutch in
 

·
Registered
Joined
·
125 Posts
Hey my subaru did the same thing but i was pushing 20lbs. i had mine retuned a couple of times and it never fixxed it. I was running to lean at times. Turbos are so damn iffy with that damn AFR. i dont know if it will help but see if you can swith to an atmospheric BOV. That just purges the air out instead of plumbing it back into the intake like bypass valves. like i said i dont know if it will help but your tune is right on then its probaly something small and stupid wrong.
 

·
RIP Dennis
Joined
·
76,390 Posts
Sounds like your bashwashing your MAF...Same was happening with me when i first put my set-up on my car...

Where is your MAF located on this set-up? I cant see it from the pictures...
 

·
Registered
Joined
·
298 Posts
That my friend is some of the hardest hardcore car porn i have ever seen. Nice Ride. BTW did u get rid of the R on the back yet?
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #10
Yes I got rid of the "R" on the back.

It is backwash on the MAF, the MAF is located right next to the air filter but it is hard to tell from the pictures.... do you think a better bypass/BOV would fix the problem? I have been trying to contact Hellion but dont answer!
 

·
RIP Dennis
Joined
·
76,390 Posts
From the look of the pictures you ahve the BPV shooting the air towards the inlet of the turbo...Can you get more pictures of how the BPV is set-up and how it returns?

An upgraded BPV could help you out...

I figured the car would be vented to the autmosphere...
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #12
yea I'm not sure why hellion did it that way, everything is perfect and 100% quality on the kit but then it has backwash, but the tuner said it is no where near the backwash the powerhouse system has.... guy took his powerhouse system off and put a supercharger on it :lmao

Everytime I get into boost and gt out of it, I have to blimp the throttle some so it doesn't do it :wtf
 

·
RIP Dennis
Joined
·
76,390 Posts
Yep same thign that happened to me...

Your backwashing the $hit out of your maf...
 

·
RIP Dennis
Joined
·
76,390 Posts
I think the bend in the pipe might be causeing some of your issues...The one coming right off the BPV...I think a better BPV and someone to straigten the discharge tube for the BPV and you should be set...
 

·
RIP Dennis
Joined
·
76,390 Posts
Dont think so but then again I am not sure how your tune is...

My tune would jsut get extremely fat whenever I would let up on the throttle...I fixed it quickly because I did not like it...

I cant see a wideband in your picture so Im guessing you dont have one...

Are you using an xcal2 for tuning? You could datalog with the XCAL2 if you have it...

You could fix it without getting a new BPV...You jsut need to have the tube that comes from the BPV modified...
It will get annoying...
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #18
Ok I will talk to the tuner about it.... I have it SCT tuned and the A/F is pretty much perfect on it.

It starts at around 14 at idle then it is almosta straight line across at 12 through the RPM range and right at 6.5RPM it dips to 11.5 (this is at 101 degrees in the shop)
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #19
I just got off the phone with Hellion and they said I should be able to hit full boost then pop it into neutral without it backwashing, so I called the tuner and he is going to have me bring it back on monday and we are going to throw it back on the dyno and check all the fitting and the BPV, hopefully everything works out!

Next on the list is a Boost Controller to get one more PSI out of it
 

·
RIP Dennis
Joined
·
76,390 Posts
I was just wanting you to check what the A/F is doing when you let off of it (and it backwashes)...

And yes the putting the car in neutral will work for ya...I had to do it for a week till I fixed mine...But it gets annoying...

Me personaly I would fix the backwash issue before doing anythign else...You can run the cooler to get mor boost out of it but me personally would want to fix the bakwash issue for no other reason then to not to have to put it neutral after a good pull...
 
1 - 20 of 34 Posts
Top