Modded Mustang Forums banner

21 - 34 of 34 Posts

·
Registered
Joined
·
1,143 Posts
Discussion Starter #21
Well, the car is dead now! had to get the wrecker to take it to the tuner this afternoon. Car all the sudden threw code for cam phaser, all 8 injectors, and EVAP, and then the typica systems check code. I also told him to fix the back wash and he said we are going to have to add to the pipeing on the intake to make coil around back towards the back of the motor... it's all a mess
 

·
May 08 ROTM
Joined
·
7,192 Posts
Regency,

I saw a post elsewhere, I'd really have to dig as it's been a month since I read. Was on like chicagosvt or chicagolandmustang. Just drawing a blank on which site it could have been.

Anyway, a guy did a single turbo install, not positive what manufacturer, but had the same codes throw. When I first read the thread it was already like 3 or 4 months old, and all their attempted remedies resulted in all or some of the same codes. I know he was extremely frustrated about backwash, but in their attempt to fix the backwash, they still threw evap codes, at which point the car went to limp mode and then a no start condition almost immediately after. Sounds like you got similar issues.

I'll do some digging, see if I can find it, so at the least you can have a sort of do's and doent's list. Maybe he came to a resolution and you and the tuner can save yourself some time..

Also, I see your postin on modular, try there as well. Numerous turbo guys over there..
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #25
I was really hopeing my car would be nice and dependable but after today I have kinda lost the faith... I'm gonna give my tuner is good chance at it and if I continue to have trouble with it... I'm going back to N/A or another poweradder (already have KB boost a pump, injectors, plugs, tuner, ect. installed)

There is nothing wrong with my tune or the install, there has to be a problem somewhere in the kit or computer system. If Hellion says there should be no backwash, then I may just have him send me another intake tube/BPV to see if that could be it, forgot to ask tuner if a better BPV would help...
 

·
RIP Dennis
Joined
·
76,390 Posts
Bro are you running the hellion tune or did your tuner put in his own?

the piping seems to be hellions fault but the codes would be your tuners if he tuned it...
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #27
I got my bets on it is Hellion's fault because the tune is dead on and very conservative...

My main concern right now is the cam phasor code it threw... hopefully it is something as simple as just the sensor and not the actual cam gear?

Chris, what would I need to do to get rid of the backwash if I dont modify my intake tube, whatever I spend money on to get rid of it, I want to make sure it completly gets rid of it after the first change I make to it... Dont wanna purchase something and then have to buy something else as well to make sure it is gone
 

·
RIP Dennis
Joined
·
76,390 Posts
Well this sounds like atune issue and if you are not running hellions tune then it cant be hellions fault for the cars codes...

The back wash issue can be remedied by someone fixing the intake piping...You can still use the parts you have you just need to have the BPV tube changed alittle to keep from getting backwash...

Or you could have you tuner change it to a blow-thru design and then you dont ahve to worry about backwashing you MAF...It would require you to ahve some work done and the tune tweaked but it would also allow you to vent to the atmosphere...
 

·
Registered
Joined
·
1,143 Posts
Discussion Starter #30
well tuner found the pipe going down from the turbo had poped off and that was causing all the stalling and weird stuff like the injector codes and evap's. Goes back on the dyno tomarrow to make sure everything is alright and he believes he can get rid of the backwash with a little change in tune :pimp
 

·
Registered
Joined
·
764 Posts
Nice thread...It scared the turbo out of me. I hope it works out for you.

Since we're on the subject...Out of 100, how many FI cars would you guys expect to need signficant up front tweaking for any reason (tuner error, install error)?
 

·
Registered
Joined
·
764 Posts
Nice thread...It scared the turbo out of me. I hope it works out for you.

Since we're on the subject...Out of 100, how many FI cars would you guys expect to need signficant up front tweaking for any reason (tuner error, install error)?
 

·
RIP Dennis
Joined
·
76,390 Posts
Figured it was tuner issues...

Tell him to roll your piping so it wont happen again...
 
21 - 34 of 34 Posts
Top