Modded Mustang Forums banner

1 - 10 of 10 Posts

·
Slappin' da Bass
Joined
·
7,835 Posts
Discussion Starter · #1 ·
I just notice here lately when i turn on my turn signals, they start blinking really fast then starts blinking normal, then they won't blink at all for a few seconds, then normal etc... Also i will just be driving and hear a sound like my turn signals are trying to come on. Could this be my turn signal relay, or the actual switch?
 

·
Registered
Joined
·
811 Posts
hmmm not sure but i know my turn signals blinked fast for like a year and then one day decided not to work. and i have looked all over for that relay and can't find it. so i still have no turn signals
 

·
Slappin' da Bass
Joined
·
7,835 Posts
Discussion Starter · #3 ·
Damn that sucks lol
 

·
Registered
Joined
·
811 Posts
yep and i actually did buy one but i can't find where i need to put it. do you know where the flasher relay is located?
 

·
Registered
Joined
·
557 Posts
Are they plugged in at the front headlights?

Might seem like an obvious answer, but this is what my problem was. I took mine to a bodyshop for a cobra bumper install and the next day I had the exact same problem. I took it to the shop and part of the headlight wasnt plugged in
 

·
Slappin' da Bass
Joined
·
7,835 Posts
Discussion Starter · #7 ·
I'll look at that
 

·
Registered
Joined
·
730 Posts
Reason for this is most likely the front or back turn signal bulbs arent plugged in/or working correctly. Try reconnecting them if they still arent working but are plugged in, that fixed my problem.
 

·
Registered
Joined
·
811 Posts
my side markers work and the emergency lights even work. just not the turn signals.:(
 

·
Registered
Joined
·
811 Posts
well i finally put the new relay in and what do you know, they still don't work. so the only thing i can figure is that the turn signal lever is bad. and of course they are more expensive:(
 
1 - 10 of 10 Posts
Top