Modded Mustang Forums banner
1 - 6 of 6 Posts

·
Who Care's ... Boost It!
Joined
·
538 Posts
Discussion Starter · #1 ·
You saw the subject... It happens around 3800-4100rpm and scares the **** out of me. When I pull over and get out and listen, it doesn't make any chattering noises, only when I pound the gas and around the rpm range it makes that noise. Could it be the clutch fan scraping the shroud or something? The sound comes from the engine bay but I so want to beleive something on the tranny side is making that noise but I go into denial LOL.

Think it's time to change the motor mounts to stablize the motor? Oh yeah I ran an 8.6 from a stopwatch to baseline a top 1/8 mile time before I hit an acutal track. Gotta get the crinks out before I go this year.
 

·
Registered
Joined
·
4,781 Posts
Clutch chatter? Maybe time for a clutch.
 

·
Who Care's ... Boost It!
Joined
·
538 Posts
Discussion Starter · #3 ·
Clutch was replaced 2 months ago. It's got a fairly new Centerforce clutch
 

·
Registered
Joined
·
4,781 Posts
How many miles do you have on the clutch? did you resurface the flywheel? They don't really break in for about 500 miles and you are supposed to not drive the car hard until after 500 street miles. Otherwise you can cause premature failure. Something else to check is the exhaust...could be vibrating up against something.
 

·
Who Care's ... Boost It!
Joined
·
538 Posts
Discussion Starter · #5 ·
It's got 35,600 miles on the car total, I know it's been over 1000 miles on the tranny. I also want to beleive, after finding a shitload of half ass work from the last guy, you think I should re-align the clutch. Like take it off, get an alignment tool and put it back on? Plus I know for a fact it's time to replace the quadrant because when I try to align the clutch by lifting up on the clutch pedal and slowing pushing it. It snaps past the plastic and doesn't click like it's adjusting(On stock quadrant too)
 

·
Who Care's ... Boost It!
Joined
·
538 Posts
Discussion Starter · #6 ·
^... Hence, it's never done this before until I did a tune up. After replacing all the spark plugs, re-did timing, replaced all vac hoses. It's suddenly started doing it but I just opened my brain zipper and found out that it could also be a lack of oil. I did put a quart in when it was running low so it's probably time to more oil. I'll do that when I get my check... I bet ya $50.00 bucks that noise goes away... It's not oiling through fast enough because it's starving for oil i bet ya
 
1 - 6 of 6 Posts
Top