Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
ok cars been popping lean in bank 1and 2 for awhile now anyway today somethng in my passenger fender started humming like crazy at first i thought it was my motor but its def coming from inside the fender whats in their
 

·
Registered
Joined
·
384 Posts
only thing i can think of is the inlet of your intake
 

·
Registered
Joined
·
96 Posts
ok cars been popping lean in bank 1and 2 for awhile now anyway today somethng in my passenger fender started humming like crazy at first i thought it was my motor but its def coming from inside the fender whats in their
It's the CCRM....Constant Control Relay Module..It controls the fuel pump relays etc.That's Definately what's making all of the noise.Does the car still run??
It's $125 at oreillys.If they actually have one in stock.You don't wanna have to buy one from Ford.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
not the intake. ya car still runs normal for about 20 mins then that noise starts and has surging idle, and its been popping p0171 p0174 could this cause it to run lean, past two weeks new maf sensor, iac,tps, 255 bbk fuel pump, fr o2s, plugs, exhaust leak welded thanks
 

·
Registered
Joined
·
96 Posts
not the intake. ya car still runs normal for about 20 mins then that noise starts and has surging idle, and its been popping p0171 p0174 could this cause it to run lean, past two weeks new maf sensor, iac,tps, 255 bbk fuel pump, fr o2s, plugs, exhaust leak welded thanks
The module runs a lot of the relays in the car including the fueling system.When mine started buzzing and went out the car quit running completely after a bit.You've replaced a lot of the sensors in the car..Is it because they went out???
Ohhh and the ccrm(part that's buzzing)is a box that's mounted on the inner fender right beside the hole where your cold air intake filter goes through.That's why it sounds like it's coming from your cold air intake.The easiest way to get to it is to pull the wheel off your car and go in from the bottom.There's no way to get to it from under the hood.
I had 2 of the modules somewhere that worked.I'll look and see if I can find them.If so I'll send you one.They're pricy new and it would suck for you to just replace it and something else be the cause of it going crazy.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #6
well i had a shop run diagnostics on it first showed me how my maf signals were all over the place and to replace it and that one of my o2s werent reading right so i did both and that didnt correct the lean code then my pump has always been loud as hell and i walked into a supply store and they had a bbk pump their so i bought it and the iac was just gross and ive cleaned that out before so i figured it was time for a new one everything else i did was prob for no good reason but it is what it is. ya got the day off tomorrow so im gonna pull it in the garage and see what i can find out its just weird that it doesnt start humming until the car warms up though ill prob try a couple junk yards around hopefully they have a couple stangs kicking around so i can snag that relay
 

·
Registered
Joined
·
96 Posts
well i had a shop run diagnostics on it first showed me how my maf signals were all over the place and to replace it and that one of my o2s werent reading right so i did both and that didnt correct the lean code then my pump has always been loud as hell and i walked into a supply store and they had a bbk pump their so i bought it and the iac was just gross and ive cleaned that out before so i figured it was time for a new one everything else i did was prob for no good reason but it is what it is. ya got the day off tomorrow so im gonna pull it in the garage and see what i can find out its just weird that it doesnt start humming until the car warms up though ill prob try a couple junk yards around hopefully they have a couple stangs kicking around so i can snag that relay
I did some digging aroung in my garage this morning and I can't find the modules I must have thrown them away.I was just going to give ya one and save ya the cash.I hate sensor/computer issues.Good luck to ya man.Unfortunately without being there to check it out this is all the help I can give ya.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #8
thanks anyways but it ended up being a faulty iac valve the thing was humming like crazy and the noise was echoing out of the air filter! took about an hour to figure that out i thought my engine was ready to blow up
 
1 - 8 of 8 Posts
Top