Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
403 Posts
Discussion Starter #1
So i had just put a new quad and FW adjuster in my car. And adjusted it properly and everything. Now the pedal wont even go down all the way. And i cant get into gear. AT ALL. It didnt start doing this until tonight on the highway. The pedal just resists being pushed in like somehtings holding it back. Im tired of working on this thing and i just want it to actually work for once. So if anyone has ever had this problem or had a clue how to fix it i would GREATLY appreciate it.
Thanks
 

·
Registered
Joined
·
997 Posts
i had a simalar problem before it was my clutch fork. the fingers that hold on to the pivot ball had worn out and the fork would slip and be in the wrong position. not saying thats whats wrong just somthing to check.
 

·
Registered
Joined
·
2,757 Posts
When did that happen?......... Sorry, I know it's not funny, but I'm sure it's not a major failure. Let me and/or Gray know when you start working on it and we'll swing by to give you a hand, a working mechanical hand.
 

·
!FACEPLATED!
Joined
·
15,305 Posts
sounds like the clutch fork fell off the pivot ball.
 

·
Registered
Joined
·
403 Posts
Discussion Starter #5
Eli i live pretty far away from you guys. I would feel bad if you inconvienced yourself for just that.
 

·
Registered
Joined
·
3,522 Posts
Hey man I don't mind. Just hace a couple cold ones ready ill drive wherever lol. But really I've gotta get ready to do the same **** to mine soon so if you need help lmk. It would be good to see what I'm getting myself into.
 
1 - 8 of 8 Posts
Top